Forum Index
The Boater's Guide to Information, Education & Scuttlebutt...
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

99 monterey 236 5.7 liter EFI loss of power

 
Post new topic   Reply to topic     Forum Index -> Mercruiser
View previous topic :: View next topic  
Author Message
cjimmydean



Joined: 27 Apr 2011
Posts: 2
Location: TN

PostPosted: Wed Apr 27, 2011 4:37 pm    Post subject: 99 monterey 236 5.7 liter EFI loss of power Reply with quote

i have a 5.7 efi that runs smooth idles fine as normal, but takes twice as long to plane, and i have lost 10mph top end.Will only turn 4000 rpm wide open even with different prop no change. Has anyone had this problem and/or know a solution to this problem

Last edited by cjimmydean on Wed May 04, 2011 7:09 pm; edited 1 time in total
Back to top
View user's profile Send private message
MikeW
Senior Member


Joined: 01 May 2006
Posts: 680

PostPosted: Wed May 04, 2011 4:01 pm    Post subject: Reply with quote

Sounds like the ignition module is going bad.
Back to top
View user's profile Send private message Send e-mail
Display posts from previous:   
Post new topic   Reply to topic     Forum Index -> Mercruiser All times are GMT - 7 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum