Forum Index
The Boater's Guide to Information, Education & Scuttlebutt...
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

1973 65 HP Johnson Powershift II Wont idle in gear

 
Post new topic   Reply to topic     Forum Index -> Johnson/Evinrude O/B
View previous topic :: View next topic  
Author Message
old boad man



Joined: 18 Feb 2010
Posts: 3

PostPosted: Thu Feb 18, 2010 6:15 pm    Post subject: 1973 65 HP Johnson Powershift II Wont idle in gear Reply with quote

I just got this boat and motor. Engine runs great at speed but wont run at trolling speed or idle so as to load on trailer or approach dock safely. Engine will always start quickly as long as manual choke is engaged. Some fancy foot work can get it in gear at a very fast idle and then quickly accellerate to speed. Intake manifold top plactic cap opposite of top carb was missing. Once it was covered things improved some but still wont run slow enough to troll or approach dock, etc. Any ideas? Thanks
Back to top
View user's profile Send private message
Hal C
Senior Member


Joined: 09 Jun 2006
Posts: 68

PostPosted: Mon Feb 22, 2010 5:06 pm    Post subject: 1973 65 HP Johnson Powershift II Wont idle in gear Reply with quote

Hello old boad man, Mike W should be able to help you with your Johnson question. He knows those old motores well. Which sort of dates him I suppose. He was slammed today with customers but I'll ask him tomorrow to reply with some ideas.
Back to top
View user's profile Send private message
djunt



Joined: 19 May 2006
Posts: 11

PostPosted: Tue Feb 23, 2010 8:44 am    Post subject: Reply with quote

Sounds like the engine is running lean, i would check for any vacuum leaks or it may be time to take the carbs off and clean them you could have dirt in them. We can certainly help with kits.
Back to top
View user's profile Send private message
old boad man



Joined: 18 Feb 2010
Posts: 3

PostPosted: Fri Feb 26, 2010 3:43 pm    Post subject: Reply with quote

djunt wrote:
Sounds like the engine is running lean, i would check for any vacuum leaks or it may be time to take the carbs off and clean them you could have dirt in them. We can certainly help with kits.


Thanks. I ordered a fuel pump kit. I am sure that my elec choke is not working also. I will try to test it with 12V leads. Should the choke be wired to the key switch as well? This was a botched mess when I got it. I like the older equipment but have no experience with boat motors.
Back to top
View user's profile Send private message
old boad man



Joined: 18 Feb 2010
Posts: 3

PostPosted: Mon Mar 15, 2010 5:35 pm    Post subject: More info please? Reply with quote

old boad man wrote:
djunt wrote:
Sounds like the engine is running lean, i would check for any vacuum leaks or it may be time to take the carbs off and clean them you could have dirt in them. We can certainly help with kits.


Thanks. I ordered a fuel pump kit. I am sure that my elec choke is not working also. I will try to test it with 12V leads. Should the choke be wired to the key switch as well? This was a botched mess when I got it. I like the older equipment but have no experience with boat motors.
Quote:
Still having problems after receiving a fuel pump kit in mail order...wrong kit all is identical except gaskets for a shorter pump body.
disassembled and check for pin holes and dirt. all was ok. Removed and cleaned carbs...found some dirt in middle carb idel jet. Am curious about vacuum leak I don't see any vacuum lines. have a vacuum diagram?
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic     Forum Index -> Johnson/Evinrude O/B All times are GMT - 7 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum