Forum Index
The Boater's Guide to Information, Education & Scuttlebutt...
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

No Electrical power to Igition Switch

 
Post new topic   Reply to topic     Forum Index -> Mercruiser
View previous topic :: View next topic  
Author Message
a4jock



Joined: 17 Jul 2011
Posts: 1

PostPosted: Sun Jul 17, 2011 7:50 pm    Post subject: No Electrical power to Igition Switch Reply with quote

'87 Mercruiser (MCM205)w/Alpha 1 drive. Getting boat ready for first run this season. New batteries installed. Turned IGN Switch and NO power to gauges and no crank. All fuses good and 50 Amp CB has continuity. Batt selector tests OK. Have not contorted enough to get to back of starter to check fuse/conections.
Boats been trouble free and a strong runner for years. It is a trailered craft and runs in fresh H2O.
Any ideas??
Back to top
View user's profile Send private message
MikeW
Senior Member


Joined: 01 May 2006
Posts: 680

PostPosted: Fri Aug 19, 2011 8:02 am    Post subject: Reply with quote

The first thing you need to check is if you are getting power to the ignition switch. Cool
Back to top
View user's profile Send private message Send e-mail
Display posts from previous:   
Post new topic   Reply to topic     Forum Index -> Mercruiser All times are GMT - 7 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum