Forum Index
The Boater's Guide to Information, Education & Scuttlebutt...
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

Loss of power 99 Mercruser 5.7 liter EFI Any solutions?

 
Post new topic   Reply to topic     Forum Index -> Other Engines
View previous topic :: View next topic  
Author Message
cjimmydean



Joined: 27 Apr 2011
Posts: 2
Location: TN

PostPosted: Wed Apr 27, 2011 2:07 pm    Post subject: Loss of power 99 Mercruser 5.7 liter EFI Any solutions? Reply with quote

I have a 99 Monterey 236 w/ 5.7 liter EFI with no power. It is a 55 mph boat, and all of a sudden will run only 45mph. Seems to be governed. Runs smooth, revs fine, just lost its gittyup. Takes alot longer to plane. Any solutions?
Back to top
View user's profile Send private message
MikeW
Senior Member


Joined: 01 May 2006
Posts: 680

PostPosted: Wed May 04, 2011 3:59 pm    Post subject: Reply with quote

If you have fresh fuel and it does not turn up it may be the ignition module. Take it to a Mercruiser Dealer and plug it into the computer. Cool
Back to top
View user's profile Send private message Send e-mail
Display posts from previous:   
Post new topic   Reply to topic     Forum Index -> Other Engines All times are GMT - 7 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum